


 

Etape 1 : notre première pièce 
 
Le bloc  est l'unité la plus petite d'un monde virtuel. On le trouve sous différentes formes, carrés, cylindres, 
triangles ou sphères. On peut le faire tourner, le déformer ou le déplacer. 

Si vous êtes 
impatient  
 
Démarrez WED, 
ouvrez le petit exemple 
OFFICE.WMP qui se 
trouve dans le 
répertoire WORK file > 
Open puis cliquez sur 
Build assurez-vous 
que seul ‘level map’ 
soit coché. Cliquez sur 
GO puis à la fin OK et 
Run . Et promenez-
vous dans le niveau. 
Echap puis quit puis 
Yes pour quitter 

 
1 Préparons notre surface de travail. Démarrons un 

nouveau niveau : File > New (Ou Ctrl+N ). Par 
défaut vous trouvez 4 fenêtres, en haut à gauche, la 
vue de dessus, en bas à gauche la vue de derrière, 
en bas à droite la vue de coté et en haut à droite la 
vue 3D. Les touches F5 à F8 permettent un rendu 3D 
allant du mode fil de fer au mode texturé. 

 

 
 

2 Puis chargeons notre bibliothèque de texture  

Texture>texture manager. Puis Add Wad, 
sélectionnez standard.wad et fermez la fenêtre. Les 
textures apparaissent sur la droite. Nous sommes 
fin prêts. Ces textures sont de simples fichiers 
PCX, 8 bits ou couleur vraie que l'on peut créer soit 
même avec son logiciel de peinture préféré. 

 

 
3 La première chose à faire est de créer un 

bloc qui représentera la pièce que nous 
voulons construire. Object > Add primitives 
> Cube(large). Il y a un large choix de 
primitives, cubes, maisons, cylindres, 
sphères…Par défaut la primitive se 
positionne toujours au centre de votre écran. 

World Editor 
 
Le World éditeur 
(WED) est le logiciel 
que vous devez lancer 
pour réaliser ce tutorial. 
C'est l'éditeur de 
niveau qu'il ne faut pas 
confondre avec le 
logiciel MED, l'éditeur 
de modèles, que nous 
n'aborderons pas ici. 

 
4 Actuellement ce cube n'est pas assez grand pour 

faire une pièce. Nous allons l'agrandir Tout d'abord 
zoom arrière avec la touche A. Puis en cliquant sur la 
touche S on sélectionne l'outil Scale. Déplacez en 
cliquant gauche et en faisant glissez la souris jusqu'à 
obtenir un cube de 6 carrés de long, 4 carrés de large 
et 2 carrés de haut. A faire dans les 3 vues. Un petit 
carré de la grille représente environ 30cm en réalité. 

 

 
5 Pour en faire une pièce nous devons 

maintenant creuser ce cube. Faites Edit > Hollow 
Block ou Alt+H. Assurez-vous avant chaque 
manipulation que l'objet sur lequel vous travaillez 
est toujours sélectionné c'est à dire en rouge. Cette 
opération génère des épaisseurs à notre cube, 
épaisseur paramétrable mais nous garderons la 
valeur par défaut. 

 

 
6 Appliquons maintenant une texture par un 

double clic sur celle de notre choix dans la 
partie droite. Nous verrons à l'étape 2 
comment nous pouvons modifier chaque 
texture. Si votre vue 3D ne montre pas la 
texture appuyez sur la touche de fonction F7 
après avoir sélectionné la vue 3D. 

3D GAMESTUDIO et 
la toile 
 
Vous trouverez sur la 
toile une communauté 
3D GameStudion ainsi 
que de nombreux 
modèles ou textures. 
Le moteur est 
compatible avec 
l’immense bibliothèque 
Quake© et il sait 
importer de nombreux 
fichiers comme .asc, 
.3DS, .X etc. 

 
7 Nous allons à présent positionner une caméra : M 

pour se mettre en mode Move puis Objet > 
Add Position. Placez la caméra ou vous voulez à 
condition qu'elle soit dans la pièce, pas trop près 
d'un mur, du sol ou du plafond. C'est grâce à cette 
caméra que nous allons pouvoir nous déplacer dans 
notre niveau en attendant d'avoir un joueur. On utilise 
le terme de position car ces caméras ont une autre 
fonction que nous verrons à l'étape 4. 

 

 
8 Nous allons sauvegarder tout d'abord notre 

niveau : File > Save as ou Ctrl+A, nommez le 
TEST1 et sauvegardez le dans le répertoire 
WORK. Puis nous allons maintenant le compiler. 
Ctrl+B où cliquez sur le bouton Build puis cochez 
les options suivantes :  
Build : level Map, Options : preview, Fly-thru : 
enable. Et soit High Res si vous avez une carte 
video 3D. Soit No D3D si vous n'avez pas de carte 
vidéo 3D. Cliquez ensuite sur Go. Lorsque la 
compilation est terminée cliquez sur le bouton OK. 

 

 
9 Le mode Fly-Thru enable fait que le 

programme, une fois la compilation terminée, 
ouvre une fenêtre pour visualiser notre 
niveau. Déplacez-vous dans votre première 
pièce en utilisant les touches de direction, 
PagSuiv et PagPréc. Notez que vous pouvez 
passer à travers les murs avec la caméra, ça 
ne sera bien entendu plus possible avec un 
joueur. Echap pour sortir du mode de 
prévisualisation. 

 



 

Etape 2 : une ouverture, de la lumière et des textures 
 
Cette étape va nous permettre de voir une fonction importante de l'éditeur de niveau, la soustraction. Cette 
fonction permet de creuser comme un emporte pièce en pâtisserie. 

Les lumières 
 
Les lumières sont des 
éléments important 
pour le rendu 3D 
puisque ce sont elles 
qui vont donner du 
relief, de l'atmosphère 
etc. 
Dans la version que 
nous utilisons nous ne 
pouvons mettre que 
des lumières blanches.  

1 Nous allons faire une ouverture et donc créer un  

bloc qui sera l'embrasure de la porte, ce n'est pas 
obligatoire mais tellement plus réaliste. Oject > Add 
Primitives > Cube (med) . Nous lui donnons une 
taille de 2 carreaux en hauteur, 1 carreau en largeur 
et en épaisseur il faut que l'embrasure dépasse 
légèrement de chaque côté du mur. 

 

 

 
2 Nous allons maintenant creuser notre porte. 

Refaites un cube assez grand pour dépasser de 
chaque côté de l'endroit que vous voulez creuser et 
moins large et moins haut que l'embrasure. Vérifiez 
sur les 3 vues qu'il est bien placé puis : Edi t> CSG 
Substract ou Alt+S. A présent le trou est fait, il 
suffit de faire suppr pour enlever le morceau en 
trop. Donnez une texture bois à l'embrasure 

 

 
3 Avant de placer une lumière, nous allons 

placer deux colonnes qui projèteront des 
ombres. Object > Add primitives > 
Cylinders  >10 sided. Adapter à votre 
niveau. S (scale) et étirez la colonne vers le 
haut et vers la droite.  

Les textures 
 
Les textures sont de 
simples images au 
format pcx en 256 
couleurs ou couleurs 
vraies. On trouve sur le 
net une multitude de 
sites qui vous 
proposent des textures 
compatibles, l'idéal 
étant de les faire soi-
même avec son logiciel 
de peinture préféré. 
 
Le nom des textures 
est codifié pour notre 
moteur 3 D. Si le nom 
commence par sky, ce 
sera un ciel animé 
nous les verrons à 
l'étape 3), par *water ce 
sera de l'eau avec des 
reflets qui bougent et 
nous pourrions 
également avoir une 
texture animée, comme 
la flamme d’une torche, 
mais cela ne fait pas 
l’objet de ce tutorial. 

 
4 Mettez une texture marbre à cette colonne puis 

Ctrl+C pour la copier et Ctrl+V pour la coller. Ce qui 
vous fait une deuxième colonne. Placez la dans le 
coin opposé. Vous pouvez mettre une texture 
différente si vous le souhaitez. Cela vous permettra 
de voir les différences avec les lumières. 

 

 
5 Nous allons à présent positionner des lumières 

Objet>Add light ce qui a pour effet de faire 
apparaître une petite ampoule. Vous pouvez régler 
les propriétés de cette lumière par clic droit puis 
propriétés. Avec cette version Red et Green ne 
servent pas. Blue sert à la brillance (0 à 255) et 
Range donne l'étendue de la lumière. Avec une 
valeur de range à 0, vous n'avez aucune lumière. 
Amusez-vous avec différentes valeurs et plusieurs 
lumières disposées derrière un poteau, en haut de 
la porte etc. 

 

 
6 Dans notre niveau, la lumière n'est pas 

matérialisée. Vous pourriez le faire, mais ce 
n'est pas obligatoire, en plaçant un objet 
comme une torche, une ampoule ou tout autre 
objet pouvant générer une source lumineuse. 
Pour tester le niveau, sauve-gardez puis 
compilez comme nous l'avons vu à la fin de 
l'étape 1. L'idéal serait d'avoir un sol et un 
plafond différents des murs. 

 
7 Nous sélectionnons la pièce qui nous intéresse 

puis nous utilisons l’outil de niveau hiérarchique bas 
que nous obtenons par Ctrl+Pagsuiv ou Objet > 
scope > Scope Down. Votre vue change et seule la 
pièce sélectionnée apparaît. Vous pouvez 
maintenant sélectionner les parties de la pièce 
individuellement et mettre une texture pour le sol, 
une autre pour les murs etc. 

 

 
8 En refaisant scope down sur un mur, vous 

redescendez d'un niveau et cette fenêtre apparaît. 
En utilisant next et prev vous pourrez mettre une 
texture différente à chaque côté du mur; (extérieur 
en pierre et intérieur en plâtre par exemple. La 
partie active apparaît en jaune. Vous pouvez jouer 
sur X scale et Y scale pour diminuer ou agrandir 
votre motif de texture et sur Angle pour changer 
l'orientation de la texture. 

 

 
9 Lorsque vous avez terminé, niveau 

hiérarchique haut par Ctrl+Pagpréc ou Objet 
> scope > Scope Up autant de fois que 
nécessaire.  Essayez et regardez le résultat. 
(Sauvegarde par Ctrl+S, puis compilation 
Ctrl+B, GO puis OK. C'est quand même plus 
agréable de vivre dans une pièce comme 
celle là. Mais pour les claustrophobes nous 
allons créer un extérieur avec un ciel. 

 



 

Etape 3 : Un extérieur, un ciel, de l'eau et une porte… 
 
Cette étape va nous permettre de créer un extérieur pour notre niveau, de mettre un ciel, un peu d’eau, et de 
créer notre première 'entité', une porte. 

Le zéro et l'infini 
 
Les moteurs 3D 
n'aiment ni le vide, ni 
l'infini. Aussi lorsque 
nous souhaitons faire 
des extérieurs il est 
impératif qu'ils soient 
clos. Nous utilisons 
généralement des 
astuces comme des 
rochers ou des 
rivières, ici nous 
utiliserons simplement 
une cour fermée par 
un muret. 
 
Dans le même esprit, il 
est impératif que notre 
niveau soit enclavé 
dans un grand cube 
qui aura en la 
circonstance l'aspect 
du ciel. Cette enclave 
est obligatoire, même 
lorsque nous ne 
faisons que des 
niveaux intérieurs, 
pour les tests de 
collision. 

 
1 Pour notre cour fermée, nous créons un cube, 

nous l’agrandissons et le positionnons de telle sorte 
que sa base touche le sol de notre pièce, sur une 
demi-hauteur et nous le faisons dépasser de chaque 
côté suffisamment grand pour qu’un personnage 
puisse s’y déplacer. 

 

 
2 Nous creusons ce cube, Alt+H, nous 

sélectionnons l’outil niveau hiérarchique bas, 
Ctrl+PagSuiv ou Objet > scope > Scope Down, 
puis nous sélectionnons le ‘plafond’ puis suppr 
pour l’enlever, et mettons une texture pour les murs 
et une pour le sol. Lorsque vous avez terminé 
niveau hiérarchique haut par Ctrl+Pagpréc ou 
Objet > scope > Scope Up. Si vous visualisez 
votre niveau maintenant vous ne voyez rien à 
l'extérieur car il fait noir.  

 

 
3 Pour obtenir les paramètres du soleil, File 

> Map Properties et nous nous intéressons 
aux 4 dernières lignes. Vous notez au passage 
que l'on peut mettre du brouillard. On peut 
garder les valeurs par défaut de sun azimut (0 
à 360 °) et de sun elevation (0 à 90°). On va 
par contre donner une valeur aux trois champs 
Sun qui correspondent aux valeurs Rouge Vert 
Bleu. Et à Ambient qui correspond à la 
luminosité   

 
4 Pour le ciel nous recréons un cube qui englobe 

l’ensemble de notre niveau, nous le creusons Alt+H, 
et nous lui appliquons une texture ‘sky’. Le cube doit 
déborder largement de chaque coté. Lorsque le 
système trouve une texture dont le nom commence 
par sky, il sait que c'est une texture animée type ciel 
vous pourrez donc voir les nuages avancer dans 
votre ciel lorsque vous exécuterez le niveau. 

 

 
5 Comme vous pouvez le voir ce moteur gère 

aussi bien les intérieurs que les extérieurs ! 
Lorsque vous aurez un peu de pratique vous 
saurez faire avancer le soleil pour représenter une 
journée entière. De la même façon on sait gérer 
différentes textures pour le ciel et différentes 
vitesses. Je vous laisse déjà essayer différentes 
valeurs pour sun azimut et pour sun élévation. 
Observez les ombres et les textures, elles 
devraient changer. 

 

 
6 Nous allons à présent créer un bassin 

d’eau dans notre cour. Nous faisons un 
premier cube, nous lui donnons une forme 
parallélépipèdique pas trop haute, nous le 
creusons (Alt+H), nous sélectionnons l’outil 
niveau hiérarchique bas, Ctrl+PagSuiv, 
sélectionnons le ‘haut' puis suppr pour 
l’enlever, nous posons notre bassin sur le sol 
et lui donnons une texture. A présent 
remplissons-le d'eau… 

 

 
7 Créons un deuxième parallélépipède qui 

représentera l’eau, qui doit être d'une taille 
légèrement inférieure à notre bassin. Il ne faut pas le 
creuser et son haut doit être légèrement en dessous 
du niveau du bassin. Les côtés étant à environ la 
moitié de l'épaisseur du bassin et le fond pouvant 
dépasser sous le bassin puisqu'il n'est pas visible.(Z 
et A pour le zoom). Nous appliquons une texture 
*water. A noter que cette eau pourrait être 
transparente si elle était importée en tant qu'entité 
(étape 4). 

 

 
8 Maintenant nous allons mettre une porte à cette 

embrasure. Je serais tenté de dire : allez-y, vous 
savez le faire, un cube qu'on aplatit, une texture 
bois et voilà une belle porte. Oui mais bien que 
belle cette porte sera inefficace car nous ne 
pourrons  pas l'ouvrir. Pour permettre à une entité 
de réagir, elle doit être importée dans notre niveau, 
donc être conçue à l'extérieur. Pour le gabarit, nous 
allons utiliser notre embrasure. On la sélectionne 
puis on la copie dans le presse papier Ctrl+C. 
 

 

 
9 Démarrons un nouveau niveau : cf. étape 1 

pas 1 et 2. Edition coller (Ctrl+V) Créons notre 
porte, c’est à dire un cube plat, de la hauteur et 
de la largeur de notre embrasure. Il faut 
simplement veiller à ce que le coin inférieur 
gauche corresponde à l’origine de notre grille 
(l’intersection des lignes vertes) Appliquez une 
texture bois, effacez l'embrasure, Ctrl+A, 
nommez le nporte et sauvegardez le dans le 
répertoire WORK. puis compilez votre niveau 
par Ctrl+B 

 



 

Etape 4 : Votre mission, si vous l'acceptez : libérer le bouclier 
 
En philosophie une entité est un être, une existence, une chose. Dans notre programme une entité est une 
‘chose’ qui peut se déplacer, réagir face à certains évènements. Comme une porte ou un joueur ! 

Les entités 
 
Il y a 4 sortes d’entités. 
Les ‘modèles’ c’est à 
dire des objets 3D 
animés comme des 
personnages. Les 
‘sprites’ petites images  
qui donnent l’illusion 
d’un 3D comme des 
lampes, des plantes, 
des flammes. Les 
entités cartes, d’autres 
niveaux, des ponts, des 
portes etc. et des 
entités terrain (que nous 
ne verrons pas dans 
ces étapes). Vous 
trouverez dans le 
répertoire prefabs de 
nombreuses entités 
comme des ponts, des 
arches, des véhicules, 
des fournitures, des 
lampes, des avions, 
plantes, véhicules etc. 
 
Les actions 
 
Sans entrer dans le 
détail, un certain 
nombre d’actions 
existent comme de faire 
ouvrir une porte, faire 
monter et descendre un 
ascenseur, faire 
patrouiller une entité, la 
faire tirer etc.  
Vous pouvez bien 
entendu créer vos 
propres actions mais 
cela ne fait pas l’objet 
de ce tutorial. 

 

 
1 Revenons dans notre niveau, file > open, puis 

chargeons la porte, Object Add Map Entity cliquez 
sur nporte.wmb. Plaçons la dans l’embrasure et 
faisons en sorte que cette porte puisse s’ouvrir 
lorsque le joueur le souhaite. Tout d’abord, générons 
un fichier de scénario, file > map properties, clic sur 
le bouton new de script, fermez la fenêtre puis Clic 
droit avec toujours la porte de sélectionnée, 
proprerties, clic sur le bouton ndef de action, 
sélectionnez 
door puis OK. La porte pourra s’ouvrir en cliquant 
dessus avec la souris ou en pressant la barre 
espace lorsque le joueur sera à coté. Sauf que vous 
n'allez pas vous en sortir comme cela, nous allons la 
fermer à clé et il vous faudra trouver la bonne clé. 

 

 
2 Nous allons maintenant voir un autre type 

d'entité, les sprites qui sont en fait des illusions 3D 
car en 2 D. Nous allons placer une plante, qui se 
prête bien à cette illusion, dans notre niveau. 
Object > Add Sprite > ZYPR.PCX. Posez la ou 
vous voulez dans votre niveau, sur le sol. Le sprite 
à la particularité d'être toujours vu de face quelque 
soit l'endroit d'ou vous le regarder. Si vous 
souhaitez créer votre propre sprite, le noir en 
position 0 est utilisé pour la transparence. 

 

 
3 Puis nous plaçons un garde à l’extérieur. 

Object > Add Model > Guard.mdl. Nous le 
posons sur le sol à l'extérieur. Selon la taille 
de vos bâtiments il se peut que l'échelle ne 
soit pas respectée mais cela n'a pas 
d'importance dans notre cas. Si vous 
souhaitez le faire tourner dans une direction 
particulière, mettez vous dans la vue  Top puis 
R puis cliquez/glisser la souris sur la gauche 
ou sur la droite (le garde étant sélectionné). Si 
vous avez la curiosité d'exécuter le niveau 
vous verriez le garde bouger de façon étrange. 
En l'absence d'ordre précis il exécute toutes 
les animations qu'il est capable de faire. Nous 
allons remédier à cela en lui proposant de 
patrouiller autour de notre terrain. 

 
4 Pour ce faire nous allons positionner 4 jalons, un 

dans chaque coin.  Premier jalon  Object > Add 
Position C'est en fait une caméra que vous posez 
légèrement au dessus du sol dans un coin mais en 
laissant assez d'espace autour et la faisant pointer 
vers le prochain jalon. Nous répétons cette opération 
encore 3 fois (4 jalons) chaque jalon pointant vers le 
suivant. Utilisez R pour les faire tourner. Demandons 
à notre homme de patrouiller : clic droit sur l'homme 
sélectionné, properties, ndef, patrol, Ok 

 

 
5 Nous allons à présent 'monter' un petit 

scénario. Votre mission, si vos l'acceptez sera de 
libérer le bouclier qui vous protègera de vos 
ennemis… Afin de ménager le suspens il y aura 
peu d'explications pour ce qui suit. Une fois que 
vous aurez joué vous pourrez revenir dessus et 
essayez de comprendre. Nous plaçons 2 épées 
dans la pièce : object > Add Model > Mace.mdl. 
(nous le faisons 2 fois). Nous les mettons derrière 
nos colonnes. Nous en sélectionnons une, clic 
droit, properties, key dans action et 2 dans skill4. 

 

 
6 Avant de paramétrer la deuxième épée, 

nous sélectionnons une des 4 caméras qui 
servent de jalon au garde à l'extérieur et 
notons les 3 valeurs qui apparaissent en bas 
à droite de votre écran (coordonnées X,Y et 
Z). Dans notre cas 448, 332 et –114..Nous 
cliquons sur la deuxième épée, clic droit 
properties et nous entrons ces valeurs 
respectivement dans skill1, skill2 et skill3. 
Puis nous mettons 'teleporter' comme action. 

Et après… 
 
On peut faire tirer le 
garde dés qu’il nous 
voit, passer à un 
deuxième niveau etc. 
 
Vous l’avez compris ce 
logiciel permet de faire 
mille autres choses, les 
2 plus importantes étant 
la réalisation de ses 
modèles animés avec le 
logiciel MED fourni en 
standard, la deuxième 
la réalisation de ses 
propres actions. 
 
Ce sera peut-être l'objet 
d'autres articles si celui-
ci vous a plu. 

 
7 Nous plaçons à présent une deuxième porte à 

45° dans un angle (Object Add Map Entity cliquez 
sur nporte.wmb. ), un bouclier derrière cette porte 
(object > Add Model > shield.mdl), 2 bâtons à 
l'extérieur (object > Add Model > Staff.mdl) et notre 
joueur dans la pièce (object > Add Model > 
Warlock.mdl). Action pour nos bâtons  Key et skill4 
à 3 pour l'un et 1 pour l'autre. Pour notre joueur 
action = player_walk. Pour la 2

ème
 porte action = 

gate , skill4 = 3 et transparent de coché, et action = 
ent_rotate pour le bouclier 

 

 
 

8 Il est temps d'exécuter notre programme et non 

plus de le regarder dans le mode  fly-Thru .Nous 
sauvons notre niveau, Ctrl + S , le compilons avec 
Ctrl+B mais cette fois ci on décoche Fly-thru 
enable puis Go. Et OK sur la fenêtre Map Compiler. 
Et il ne se passe rien ce qui est normal. Il faut 
exécuter votre niveau par le bouton run ou F9. Ce 
qui change, c'est que vous ne passez plus à 
travers les murs. Il faut passer par les portes et 
donc les ouvrir et pour cela il faut la nonne clé  
 

 

 
9  Pour    ouvrir une porte (lorsqu'on est 

près d'elle barre espace ou clic souris), vous 
ne voyez pas votre propre joueur (Ses yeux 
sont la caméra) mais la touche F7 remédie à 
cela sachant que s'il y a un obstacle entre la 
caméra et vous, ça ne se passe pas bien, on 
évite donc ce mode. Maj ou shift pour courir, 
Home pour sauter, fin pour se baisser,.etc. 
etc. Alain BREGEON 
 

 


